Sunday, 6 December 2015

2D Array DS

Problem Statement
You are given a 2D array with dimensions 6*6. An hourglass in an array is defined as a portion shaped like this:
a b c
  d
e f g
For example, if we create an hourglass using the number 1 within an array full of zeros, it may look like this:
1 1 1 0 0 0
0 1 0 0 0 0
1 1 1 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
0 0 0 0 0 0
Actually, there are many hourglasses in the array above. The three leftmost hourglasses are the following:
1 1 1     1 1 0     1 0 0
  1         0         0
1 1 1     1 1 0     1 0 0
The sum of an hourglass is the sum of all the numbers within it. The sum for the hourglasses above are 7, 4, and 2, respectively.
In this problem, you have to print the largest sum among all the hourglasses in the array.
Note: If you have already solved the problem "Java 2D array" in the data structures chapter of the Java domain, you may skip this challenge.
Input Format
There will be exactly 6 lines of input, each containing 6 integers separated by spaces. Each integer will be between -9 and 9, inclusively.
Output Format
Print the answer to this problem on a single line.
Sample Input
1 1 1 0 0 0
0 1 0 0 0 0
1 1 1 0 0 0
0 0 2 4 4 0
0 0 0 2 0 0
0 0 1 2 4 0
Sample Output
19
Explanation
The hourglass possessing the largest sum is:
2 4 4
  2
1 2 4
Copyright © 2015 HackerRank.
All Rights Reserved


#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>

int main() {

    /* Enter your code here. Read input from STDIN. Print output to STDOUT */  
    int i, j, count = -63, in[6][6];
    for( i = 0 ; i < 6 ; i++ )
        {
        for( j = 0 ; j < 6 ; j++)
            {
            scanf("%d",&in[i][j]);
        }
    }
    for( i = 0 ; i < 4 ; i ++)
        {
        for( j = 0 ; j < 4 ; j ++)
            {
            int t;
            t = in[i][j] + in[i][j+1] + in[i][j+2] + in[i+1][j+1] + in[i+2][j] + in[i+2][j+1] + in[i+2][j+2];
            if( t > count )           
                {
                count = t ;
            }
        }
    }
    printf("%d",count);
    return 0;
}

No comments:

Post a Comment